Article delegate-en/504 of [1-5169] on the server localhost:119
  upper oldest olders older1 this newer1 newers latest
search
[Top/Up] [oldest] - [Older+chunk] - [Newer+chunk] - [newest + Check]
[Reference:<_A503@delegate-en.ML_>]
Newsgroups: mail-lists.delegate-en

[DeleGate-En] Re: Running Delegate as a REAL WindowsNT-Service
24 Jun 1999 05:21:36 GMT ysato@etl.go.jp (Yutaka Sato)


On 06/23/99(16:09) you p64aqbdyi-y44oklh7zdjr.ml@ml.delegate.org wrote
in <_A503@delegate-en.ML_>
 |I can: Running Delegate from Commandline or from a Batch (Script) without problems
 |I want: 
 |Running Delegate fully automatically at WinNT-startup  (like Original IIS or some other services)
 |I dont want to use srvany if possible. A real NT-Service is better.
 |
 |Is this functionality possibly built-in ?
 |What kind of settings i have to do?
 |Registry? Command-line? Both?
...
 |ps.: Delegate runs on Win2000b3 without problems....

DeleGate automatically make itself a service when it feel that
it is running on WinNT, like this:

> dg5_9_2.exe -P8080 ADMIN=ysato@etl.go.jp
DeleGate/5.9.2 (June 2, 1999)
AIST Research Product No. 1994-ETL-8715-1
Copyright (c) 1994-1999 Yutaka Sato
Copyright (c) 1994-1999 Electrotechnical Laboratory (ETL), AIST, MITI
--
FTP: <URL:ftp://ftp.etl.go.jp/pub/DeleGate/>
WWW: <URL:http://www.etl.go.jp/~ysato/>
Mailing-List: <URL:mailto:delegate@etl.go.jp>
              <URL:http://wall.etl.go.jp/delegate/ml/>
Trying to start as a service [DeleGate Server -P8080] ...
OK. The service is created successfully.
OK. Parameters are saved in registory:
"HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DeleGate-P8080\Parameters"
OK. Environments are saved in registory:
"HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DeleGate-P8080\Environments"
OK. The service started successfully.


If it does not act like this on Win2000, I'm not sure but something
should be canged in "rary/winserv.c": create_service() and
start_services() especially.

Cheers,
Yutaka
--
Yutaka Sato <ysato@etl.go.jp> http://www.etl.go.jp/~ysato/   @ @ 
Computer Science Division, Electrotechnical Laboratory      ( - )
1-1-4 Umezono, Tsukuba, Ibaraki, 305-8568 Japan            _<   >_

On 04/12/99(15:22) I wrote
in <_A410@delegate-en.ML_> (nntp://wall.etl.go.jp/mail-lists.delegate-en/410):
 |On 04/10/99(20:08) you "Sergius Lezhnin" <ptaaqbdyi-y44oklh7zdjr.ml@ml.delegate.org> wrote
 |in <_A408@delegate-en.ML_>
 | |Is there any possibility to run DeleGate automatically on Windows NT,
 | |like service?
 |
 |Subject: [DeleGate-En] Re: Delegated as a NT service
 |On 03/30/99(11:19) I wrote in <_A383@delegate-en.ML_>
 | |On 03/30/99(01:01) you "Ph. Gautier" <ppyaqbdyi-y44oklh7zdjr.ml@ml.delegate.org> wrote
 | |in <_A382@delegate-en.ML_>
 | | |I'm tring to use Delegated under NT, but I can't find any dedicated
 | | |information.
 | | |Mainly, it's said Delegated can be run as a NT service. May I have any
 | | |further information, how can I managed this.
 | |
 | |When DeleGate runs on WindowsNT, it automatically registers itself
 | |as a service and start the service.  For example, if you need a
 | |DeleGate as a HTTP proxy server, just say like this:
 | |
 | |  > dg5_9_1.exe -P8080 ADMIN=you@host..
 | |
 | |Then you will see a service running named "DeleGate Server -P9999"
 | |Log files and caches are located at "\Program Files\DeleGate\" by
 | |defalult.
 | |
 | |Cheers,
 | |Yutaka
 | |--
 | |Yutaka Sato <ysato@etl.go.jp> http://www.etl.go.jp/~ysato/   @ @ 
 | |Computer Science Division, Electrotechnical Laboratory      ( - )
 | |1-1-4 Umezono, Tsukuba, Ibaraki, 305-8568 Japan            _<   >_
 |
 |Cheers,
 |Yutaka
 |--
 |Yutaka Sato <ysato@etl.go.jp> http://www.etl.go.jp/~ysato/   @ @ 
 |Computer Science Division, Electrotechnical Laboratory      ( - )
 |1-1-4 Umezono, Tsukuba, Ibaraki, 305-8568 Japan            _<   >_

  admin search upper oldest olders older1 this newer1 newers latest
[Top/Up] [oldest] - [Older+chunk] - [Newer+chunk] - [newest + Check]
@_@V