Article delegate-en/1259 of [1-5169] on the server localhost:119
  upper oldest olders older1 this newer1 newers latest
search
[Top/Up] [oldest] - [Older+chunk] - [Newer+chunk] - [newest + Check]
[Reference:<_A1257@delegate-en.ML_>]
Newsgroups: mail-lists.delegate-en

[DeleGate-En] Re: rewriting problem with cgi program
30 Jul 2001 08:45:19 GMT feedback@delegate.org (Yutaka Sato)


Hi,

Maybe I found the cause of the problem :-)

On 07/29/01(15:56) I wrote in <_A1257@delegate-en.ML_>
 |Situations I saw there varied depending browser, proxy, and
 |some kind of timing.  Netscape Navigator (4.75) always shows
 |empty page for https://lercnetworks.com/cgi-bin/webmail.
 |MSIE (5.00) shows login page, then MOUNTed or original page
 |after login.

The reason NN/4.75 shows empty page is that it does not
recognize 303 (See Other) response code from your server
for ".../webmail" to redirect to ".../webmail?index=1"
Specifying the redirected page by hand, I could get the
login page, but get non-rewritten original page after login.
The reason why your DeleGate does not rewrite the response
body seems that the response is encoded with "gzip" since
NN do requests with "Accept-Encoding: gzip" header field.
To solve the problem, try to remove the filed using CFI
script for FTOSV filter.

  FTOSV=noencode.cfi

[the contents of DGROOT/lib/noencode.cfi]
#!cfi
Remove/Accept-Encoding:

Cheers,
Yutaka
--
  @ @ Yutaka Sato <y.sato@delegate.org> http://www.delegate.org/y.sato/
 ( - ) National Institute of Advanced Industrial Science and Technology (AIST)
_<   >_ 1-1-4 Umezono, Tsukuba, Ibaraki, 305-8568 Japan

  admin search upper oldest olders older1 this newer1 newers latest
[Top/Up] [oldest] - [Older+chunk] - [Newer+chunk] - [newest + Check]
@_@V