Article delegate-en/1126 of [1-5169] on the server localhost:119
  upper oldest olders older1 this newer1 newers latest
search
[Top/Up] [oldest] - [Older+chunk] - [Newer+chunk] - [newest + Check]

Newsgroups: mail-lists.delegate-en

[DeleGate-En] Re: Disconnect suddenly
27 Apr 2001 01:13:30 GMT plycabdyi-ufvkztt7w23r.ml@ml.delegate.org



Dear Mr. Yutaka,

Thanks for your prompt reply.
I've followed ur post and i still got disconnected.
Here is what is in the log with -v

04/27 08:58:03.55 [4559] 1+0: CS-EOF
04/27 08:58:03.55 [4559] 1+0: CS-RELAY[18>12]: 202Bytes 145I/O buf=1024
04/27 08:58:03.55 [4559] 1+0: Kill(4562,15)
04/27 08:58:03.55 [4562] 1+0: SC-RELAY[18<12]: 9485Bytes 187I/O buf=1024
04/27 08:58:03.55 [4562] 1+0: Kill(4559,15)
04/27 08:59:03.56 [4559] 1+0: EOF from the client
04/27 08:59:03.56 [4559] 1+0: disconnected [18]
-@[202.70.130.99]202.70.130.99:3
480 (3812.400s)(0)
04/27 09:10:21.64 [4558] 1+0: DeleGate SERVER EXITS: caught SIGINT [2]
04/27 09:10:21.64 [4558] 1+0: Killpg(4558,15)
04/27 09:10:21.65 [4558] 1+0: FINISH.

I am running delegated with
delegated -P9527 RELIABLE=localhost SERVER=telnet -v PERMIT="*:*:*"
RELIABLE=* AUTHORIZER=localhost TIMEOUT=io:1h

I've done this test with "vmstat 2" running on the server that i connected.
Therefore shouldn't be IO timeout....

Please kindly help....

Leo


                                                                                                                   
                    feedback@dele                                                                                  
                    gate.org             To:     feedback@delegate.org                                             
                    (Yutaka Sato)        cc:     plycabdyi-ufvkztt7w23r.ml@ml.delegate.org                                              
                                         Subject:     Re: [DeleGate-En] Disconnect suddenly                        
                    04/25/2001                                                                                     
                    02:41 PM                                                                                       
                    Please                                                                                         
                    respond to                                                                                     
                    feedback                                                                                       
                                                                                                                   
                                                                                                                   




Hi,

On 04/25/01(15:13) you plycabdyi-ufvkztt7w23r.ml@ml.delegate.org wrote
in <_A1118@delegate-en.ML_>
 |I am using Delegate 7.1.2. as a telnet proxy from outside to my internal
 |network.
 |
 |I ran delegate with the following parameter
 |delegated -P9527 SERVER=telnet -vt PERMIT="*:*:*" RELIABLE=*
 |AUTHORIZER=localhost
 |
 |everything work fine, successfully login, authenticated , telneting to
 |other host and work on that host.
 |
 |But when i got connected around 5 mins. i got disconnected by the proxy.
 |jumping out into the initial proxy screen.

Could you use "-v" option instead "-vt" to see the reason why
DeleGate did the disconnection ?

 |I am sure that i am not idling on that terminal.

Since the default timeout on idling is 10 minutes, 5 minutes
in your case seems too short anyway.  But it might be useful
to specify the timeout explicitly like TIMEOUT=io:1h or so.

Cheers,
Yutaka
--
  @ @ Yutaka Sato <y.sato@delegate.org> http://www.delegate.org/y.sato/
 ( - ) National Institute of Advanced Industrial Science and Technology
(AIST)
_<   >_ 1-1-4 Umezono, Tsukuba, Ibaraki, 305-8568 Japan





  admin search upper oldest olders older1 this newer1 newers latest
[Top/Up] [oldest] - [Older+chunk] - [Newer+chunk] - [newest + Check]
@_@V